スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

iPhone5,iOS6でのLandscapeRightでのGame Center対応


iOS6で横画面でゲームセンターが使えなくてハマりました。

一応ここに

---------------------

*** Terminating app due to uncaught exception 'UIApplicationInvalidInterfaceOrientation', reason: 'Supported orientations has no common orientation with the application, and shouldAutorotate is returning YES'

---------------------

というクラッシュログでおちます。

調べた結果AppDelegate.mに

-(NSUInteger)application:(UIApplication *)application supportedInterfaceOrientationsForWindow:(UIWindow *)window
{
if (UI_USER_INTERFACE_IDIOM() == UIUserInterfaceIdiomPad)
return UIInterfaceOrientationMaskAll;
else // iphone
return UIInterfaceOrientationMaskAllButUpsideDown;
}

を追加。

ViewControllerに

- (BOOL)shouldAutorotate
{
return YES;
}

- (NSUInteger)supportedInterfaceOrientations
{
return UIInterfaceOrientationMaskLandscapeRight;
}

- (UIInterfaceOrientation)preferredInterfaceOrientationForPresentation
{
return UIInterfaceOrientationLandscapeRight;
}

- (BOOL)shouldAutorotateToInterfaceOrientation:(UIInterfaceOrientation)interfaceOrientation
{
return UIInterfaceOrientationIsLandscape(interfaceOrientation);
}

を追加してとりあえず動くようになりました。
どれがいけなかったのかは現在調査中ですが、とりあえずこれで動いたのでよしとします。

iOS6いろいろとめんどい。。。



スポンサーサイト

テーマ : iPhone - ジャンル : コンピュータ

TweetDeckの日本語化

TweetDeckが日本語に訳されましたね。
訳された割には説明が英語って・・・。まぁ今日出たみたいなので一応簡単な方法をここに書いておきます。
ポイントは一通り設定したあとに再起動。もしカラムがまだ英語だったら一度カラムを消して再度追加することです。

とりあえず下記のリンクに飛んでいただいてダウンロードをします。
http://blog.tweetdeck.com/its-tweetdeck-translated
いきなりダウンロードページに行ってもいいんですが、ここに設定の方法などが書いてあるので一応・・・。


少し下に行くと"Great!Where do I get it?"と書かれている部分があるのでその下の文のリンクをクリックしてください。

tweetdeck1

その後ダウンロードボタンを押して指示通りにインストールします。既に過去のバージョンをインストールしている方は上書きインストールしてください。


tweetdeck2


その後TweetDeckを起動します。

tweetdeck10


右上にある設定ボタンをクリック

tweetdeck4

その後「General」>「Languages」で「Japanese」を選択してください。そして「Save settings」で。

tweetdeck5


ここがポイント!!
TweetDeckを再起動


その後私は気がついたらカラムも含めて日本語になっていましたが、日本語でない場合はカラムを一度消して、再度追加してください。そうすると日本語になっていると思います。また再起動するのもいいかも・・・。

ではお試しを~





テーマ : ソフトウェア - ジャンル : コンピュータ

Tag : TweetDeck Twitter

Ubuntu9.10でAndroid開発環境を作るTips


何を思ったかEeePCからWindowsを消し去ってUbuntu9.10のみにしていしまいました。
今まではWubiとかいうデュアルブート的なものにしていたんですが、もしかしたらUbuntuのみの方がいいんじゃないかと血迷ってWindowsを消し去ってしまいました。とりあえず、必要なファイルはDropBoxに入れてあるのでどうにかなるだろう何て考えています。



そこで、とりあえずeclipseでAndroid開発環境をつくろうと思って始めたのですが、google先生に聞いてみても意外と完全に解説しているサイトが見つかりませんでした。
とりあえず、参考にしていたのはここのサイトです。
http://d.hatena.ne.jp/hiro_nemu/20090520/1242830595

ここで書いてあるのはEclipse3.4,Android SDK 1.5ですが、最新のEclipse3.5,Android SDK 2.1をインストールしました。ここで出た問題点はADTのセットアップをするときに

-----------------------------------------------------------------
Cannot complete the install because one or more required items could
not be found.
Software being installed: Android Development Tools
0.9.5.v200911191123-20404 (com.android.ide.eclipse.adt.feature.group
0.9.5.v200911191123-20404)
Missing requirement: Android Development Tools
0.9.5.v200911191123-20404 (com.android.ide.eclipse.adt.feature.group
0.9.5.v200911191123-20404) requires 'org.eclipse.wst.xml.ui 0.0.0' but
it could not be found
-----------------------------------------------------------------

こんな感じのエラーが出てしまって止まってしまいました。
そこでちょこちょこ探していると、
http://www.mail-archive.com/android-developers@googlegroups.com/msg69804.html
こんなサイトを見つけました。
基本的に英語だったのでちょっとだけ書いて置くと、


Go to "Help/Install New Software..."
「Help」>「Install New Software」と行って

Add http://download.eclipse.org/releases/galileo/ to the update sites list (strange it's not installed by default on ubuntu)
”http://download.eclipse.org/releases/galileo/”をアップデートサイトに足して

Restart eclipse
eclipseを再起動して

Go back to "Help/Install New Software..." and install the Android ADT
as explained on the android website.
またAndroidのサイトからADTをインストールして


見たいなことが書いてあると思います。
かなり適当に訳しているので気にしないでください。
とりあえず最初に示したサイトと一緒に使用すれば出きると思います。
この後も少し違っていて、

>Eclipseのメニューバーから「Window」>「Prefarence」で設定画面を開き、左側のAndroidを選択。すると右側
>にSDK Location:てのが表示されるのでここにAndroid SDKの場所を入れてやる。(今回はここ→/home/hiromi/apps/dev/android-sdk-linux_x86-1.5_r1)
>そして、「Apply」を押ししばらくすると以下の画面の様になる。こうなればOK。

と書いてあったのですが、「Window」>「Prefarence」で設定画面を開き、Android SDKの場所を入れてやっても全然画面の通りに表示されませんでした。

そこで、「Window」>「Android SDK and AVD Manager」を開いて、「Install Packages」から「Update All...」を押します。するとどんどんインストールされていくので、インストールが終了したら完了です。



これでとりあえずHello Androidと表示させることができたので大丈夫だと思います。
個人的には今回インストールしたeclipseにはOpen-JDKだったのでSun-JDKにしたほうがいいのかな?って思うのですが、また今度にしたいと思います。というか変えた方がいいのか分からないので誰か教えてください。

テーマ : IT関連 - ジャンル : コンピュータ

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。